Auto-home issue when ending print

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14123
    3DSOS
    Participant

    I have an issue with the new Firmware 1.2.0. With a single extruder print, using left extruder, it goes everything ok but when the print finishes, the extruder tries to reach the endstop going in opposite direction and crashes against right extruder.

    #14133
    bernatcastan
    Participant

    I have the same problem with the new firmware.
    Bernat

    #14248
    chimpusmaximus
    Participant

    I found this problem as well using S3D and decided to check if Cura did anything different at the end of a print.
    Noticed that they had a G91 and G90 command compared to what i had in my S3D. added this like below and then did not have the problem again yet.
    M104 S0 T0
    M104 S0 T1
    M140 S0 ; heated bed off
    G91
    G28 X0 Y0 ; move XY to min endstops
    M84 ; steppers off
    G90

    #14255
    fred_dot_u
    Participant

    This is what currently sits in my S3D ending script box:

    M104 S0 T0 ; turn off right extruder
    M104 S0 T1 ; turn off left extruder
    M140 S0 T0 ; turn off bed
    G91           ; switch to Relative position mode
    G1 E-1 F300 ; Retract filament before lift
    G1 Z+0.5 E-5 X-20 Y-20 F4000
    G28 X0 Y0 ; home Y and X axis
    M106 S0 ; Switch off part cooling fan
    M107 ; Alternative command for Switching off part cooling fan
    M104 S0 ; turn off temperature
    M140 S0 ; turn off Heated Bed
    M84 ; disable motors
    

    There’s a few extra lines compared to yours, but nothing that appears amiss. Your code includes a G90 at the end, but that’s insignificant, isn’t it?
    What part of my code would contribute to the problem?

    #14262
    chimpusmaximus
    Participant

    Try adding the G91 before it tries to home the axis. For what ever reason before I added this it was crashing the wrong way into the other extruder.

    #14288
    fred_dot_u
    Participant

    There is already a G91 code before the home commands, unless your suggestion was not directed to me?

    #14313
    chimpusmaximus
    Participant

    Apologies replied from smartphone and did not notice it.

    #14317
    fred_dot_u
    Participant

    Your response is encouraging. If my end g-code matches the known code that works with the update, it may be possible that an update would not cause my printer to go haywire.

    #14328
    bernatcastan
    Participant

    Thanks alot for your help. Introducing the G91 code in the ending script solved the problem!

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.