Firmware update (Sigma)

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #16456
    legrand.aida
    Participant

    Hi there! I used to have some issues with my LCD for a while. It worked, but after printing starts, LSD didn’t respond and processing stopped on 0%. After completing the print I just switched off my printer. So I’ve decided to update the firmware to 1.2.
    I started with my MAC, after several tries, I moved to Windows and tried again. It was Okay until I remove SD… SD’s broken into two parts and there no chance to repair it.
    I’ve formatted 8 and 32 GB cards to FAT16 several times, but my Sigma doesn’t want to work with them. I see the message “Drive not mounted” on LCD after the printer starts.
    I was wondering maybe is there the way to downgrade firmware and start upgrading over?

    #21895
    k3d.honduras
    Participant

    Having the same problem with mine did what was the answer?

    #22220

    Hello,
    You have all the firmware versions available on our site:
    https://github.com/BCN3D/BCN3DSigma-Firmware/releases
    For the LCD micro SD you should use a 4GB micro SD so you can format it in FAT.
    Please, send an e-mail to sat@bcn3dtechnologies.com so I can send you a guide on how to do this.

    #27914
    yann.le.roux
    Participant

    Hi,
    I have update the firmware through CURA. When I start my SIGMA R17 I can see the new updated firmware on the LCD screen. Do I still need to update the LCD micro SD card? CURA didn’t ask for it as it appear in your video?
    Thank you!

    #27936

    Hello Yann,
    what version were you updating from? if you are changing from 1.2.2 to 1.2.3 there’s no need to change the SD files.
    Cheers!

    #27992
    yann.le.roux
    Participant

    I upgrade to 1.2.3 so I am good!
    Thanks

    #30794
    alexander
    Participant

    Hi!
    Suddenly my printer started very slow and never finished boot procedure. Screen showing version number seems to be frozen.
    I searched for a solution and some posts recommended to format sd card and copy sdfiles to sd card.
    But now I’m not able to start printer.
    Old SD card seems to be defect. I get a notification on the display starting with “ADDRESS TRAP….”
    I used Windows, than mac, than Ubuntu to format a new sd card (4GB) with FAT and 64K Cluster size.
    But I always get “Mounting. Drive not mounted” message on the display.
    How can I fix this issue?
    Printer firmware: 1.2.3
    SD card files used: v120 and v122
    Thx,
    Alexander

    #30818

    Hello Alexander,
    looks like the issue may be on the micro SD itself, so you may have to change it.
    I’d recommend you to get an 8GB class 10 micro SD and format it in FAT following the process detailed on this link:
    https://github.com/BCN3D/BCN3D-Cura-Windows/wiki/Updating-the-SD-Files-from-the-LCD-Display
    The files that you should use are the v122.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.