Issue with Z Axis

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #13643
    Thomas
    Participant

    I am currently seeing an issue while attempting to calibrate my Sigma printer (I just purchased it). When attempting to home the Z axis, it will move the left extruder out, raise the bed until it activates the endstop on the extruder (I can see it showing the Z is homed in Cura), then the bed will drop approx 35mm from that height and sit there. Attempts to raise the bed past that stop (it seems to act like it is homed at the Z plane then.

    This means that the bed is approx 35mm below the print head when printing. It will also behave like this while running the calibration wizard (It will home the bed, then go through the bed leveling but the bed never touches the endstops at that point and will attempt to print with the bed at the -35mm height. Attached is the video of attempting to home the printer. The video shows the Z axis homing and then the bed dropping to the position I mentioned. As noted previously, I cannot seem to raise it past this height once it is there via Cura.

    I am currently running 01-1.1.16 and have tried reflashing the firmware, downgrading to 1.1.15 and running through the auto update to bring it back up to 1.1.16.

    #13660
    Barbecue Silver
    Participant

    Try this: Connect your Sigma via USB and start Pronterface or something similar and connect. Then send this G-Code
    M503
    Now you receive some information about the printers stored settings. As I understood, they won’t be touched by a firmware update. Check sepcially the following line of echo:Home offset (mm): It should look like this echo: M206 X0.00 Y0.00 Z0.00.
    Either you can post the whole reply of the M command here or you can restore the settings that are stored hardcoded in the printer by using M502 (restore) and after that M500 (save). For more information about the codes visit the RepRapWiki.

    #13717
    Thomas
    Participant

    As an update, resetting it via G-Code worked. Sadly, I fat fingered it and typed in 502 instead of 503 so I didn’t see what the settings were but after the reset, it functioned as expected.
    Thank you, Barbecue, for the assistance.

    #13728
    Barbecue Silver
    Participant

    Thank you for telling that it worked 🙂
    Glad to help you!

    #26078
    kfoisy
    Participant

    I am having similar issue except that when I try to calibrate Z-Axis, the bed will raise to about 2-3mm from the head and then won’t go up any more. I tried the suggestion above, to check settings and reset to factory. Command executed fine but nothing changed.
    I am just setting this up for first time and have not even been able to successfully calibrate.
    Kevin

    #27905
    vendor
    Participant

    Kevin – did you ever get a solution to your problem. Just got my printer last night and I was able to load the filament and perform the bed leveling successfully. However, on the first/left z-axis extruder calibration the head will maintain 2-3 mm above the bed when attempting to perform the paper calibration. I tried to manually override it but the bed won’t budge or acknowledge the commands to move the z-axis.

    #27990
    vendor
    Participant

    For future reference for anyone who encounters this. I changed the offset in the EPROM by issuing the following commands:
    M206 X0.0 Y0.0 Z-2.4
    M500
    Obviously set the Z offset to whatever you need. It’s better to go with a lower number initially so you don’t crash the nozzle into the glass. M500 persists the offsets in the EPROM.

    #31199
    stevengreenstein
    Participant

    I just opened my Sigma and set it up. The bed won’t move! Instead, it just makes a very loud noise. Any advice?

    #31932
    jmattdayton
    Participant

    I posted on a separate thread, but i’ll add on here too. I’ve had a Sigma for 10 months but just upgraded to the new R17 step and fan drivers about a month ago. Was working fine, but recently the Z axis has gone awry. When trying to run the bed calibration, the bed only moves down and never moves upwards to properly contact the endstops. I’ve even tried manually adjusting the bed during the z calibration step to move it up to the nozzle end and then adjust it properly with the interface. After you accept, it just drops back to 20-30mm or so and print fails. It was doing this with the old firmware, i then updated the firmware, did not fix the issue. Printer is useless until this is fixed an i’m about out of ideas. Tried the other solutions i saw on this thread using Repetier Host direct connection interface.
    When using the manual interface, noticed that the Z ‘Home’ value just changed itself arbitrarily. If i used the Z home command, the bed moved up a little, down more, and then decided that was the new zero value. Without using G92 commands, the z axis would no longer move higher than that value.
    Please look into this. My printer is now useless until this is resolved.

    #32578
    vendor
    Participant

    Hi Jmattdayton. I had this issue as well. After some help from support, it turned out one of the Z endstops (the thingy that is used to touch the glass bed for bed calibration was stuck on my right extruder) was stuck so the printer thought it was maxed out on height and sending the bed lower. I was able to jiggle it a bit and it worked great, otherwise, I’m told you can order replacements. Hope that helps.

    #32609
    jmattdayton
    Participant

    This indeed ended up being the issue. Unstuck the contact in the limit switch and works fine now. Thank you for the response!

    #32611
    vendor
    Participant

    My pleasure – happy printing!!!

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.