X Y calibration doesn’t save

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #6448
    jamie
    Participant

    Hi,

    I’m having some problems with my Sigma. It seems after doing a full calibration the values aren’t being stored. When I do a test print the X axis is clearly out by around 1.5mm.

    So far I’ve tried:

    formatting the LCD card
    Connecting with pronterface and sending m500, m502 commands to reset the eeprom.
    Doing a full calibration, then just a bed calibration directly after

    This all came about from me “upgrading” the X axis linear carriages. Mine had some movement in them, so I thought I would try replacing them with new ones. This removed all the movement, however it made no difference to print quality. It has however created this problem.

    So my sigma prints fine, its just permanently out of alignment.

    Any help or advice would be greatly appreciated at this point.

    Cheers
    Jamie

    #6719
    bcn3dtech
    Participant

    Hi Jamie,
    Yesterday we released a new firmware version. Try to update your Sigma using Cura: Machine –> Check for firmware updates.
    Let us know if it helped

    #6783
    jamie
    Participant

    Hi bcn3dtech,
    Thanks for your reply. I updated the firmware and the offset is now the other way. By about the same amount.
    I’ve even tried picking lines in the calibration that don’t line up, but the results are unchanged. It seems they are just not being saved to eeprom. Possibly a bad board ?
    I’m not convinced the bed levelling is working either. After getting the bed “level” I then try a print, but the front is clearly lower than the back as the prints scrape off very easy at the front, but the back you can see the filament has been pushed on very hard, to the point of not extruding in places.

    #9589
    vlad
    Participant

    Hi Jamie,
    Did you solve your problem? It seems we have something similar – X offset about 0.5 – 1 mm between the extruders. Firmware version ..5, recalibrated several times – no effect. I’ll update to 6th version and we’ll see…

    #10005
    christian.gassner
    Participant

    As i am quite happy now with single extruder print and i have started now to concentrate on dual extruder print.
    I phase exactly the same problem … x-axis is not aligned. I have done several full calibrations without success.
    I have also checked both microswitches … all ok. Currently i have loaded v1.1.6. Really strange.

    Send: M503
    Recv: echo:Steps per unit:
    Recv: echo: M92 X80.00 Y80.00 Z1600.00 E152.00
    Recv: echo:Maximum feedrates (mm/s):
    Recv: echo: M203 X250.00 Y180.00 Z15.00 E60.00
    Recv: echo:Maximum Acceleration (mm/s2):
    Recv: echo: M201 X2250 Y2250 Z80 E800
    Recv: echo:Acceleration: S=acceleration, T=retract acceleration
    Recv: echo: M204 S1500.00 T2000.00
    Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s), Z=maximum Z jerk (mm/s), E=maximum E jerk (mm/s)
    Recv: echo: M205 S0.00 T0.00 B20000 X5.00 Z0.40 E5.00
    Recv: echo:Home offset (mm):
    Recv: echo: M206 X0.00 Y0.00 Z0.00
    Recv: echo:PID settings:
    Recv: echo: M301 LEFT P15.16 I1.16 D49.38 – M301 RIGHT P15.16 I1.16 D49.38
    Recv: echo:Offsets (mm):
    Recv: echo: X 303.80 Y -0.05 Z 0.00 Z probe-1.75
    Recv: echo:Temp (???C):
    Recv: echo: L_INSERT 220.00 L_REMOVE 170.00 L_BED 65.00 L_PRINT 215.00
    Recv: echo:Temp (???C):
    Recv: echo: R_INSERT 220.00 R_REMOVE 170.00 R_BED 65.00 R_PRINT 215.00
    Recv: echo:LOG:
    Recv: echo: prints 7.00 hours print 2.00 prints finished 5.00 max temp L 274.00 max temp R 308.00 max temp B 65.00
    Recv: ok

    • This reply was modified 5 months, 3 weeks ago by artesans.
    #10007
    jamie
    Participant

    BCN can you address this please ? Seems I am not the only one having these issues.
    Vlad and Christian, do you need to do 2 calibrations to get the lines to line up ? On the first run none of mine line up, so I choose line “10” and calibrate again. Just wondering if it has something to do with needing to adjust twice.
    I’ll try calibrating it as close as possible, then do a full calibration again. See if this makes any difference.
    Using the latest firmware 1.1.6 btw.
    Cheers
    Jamie

    #10057

    Hi Guys,
    I’ve encountered this issue before a couple of times. In both cases part of the cause was a misplaced silicone cloth that made too much contact with the nozzle, causing one of the axis to be unable to reach the right position.
    The cause could also be on the drivers that control each of the X axis motors, but first make sure the cloth isn’t interfering.
    Regards,
    David Trillo

    #10079
    vlad
    Participant

    Jamie, calibration usually goes well – matching lines are close to the centre.
    David has advised me to check the silicone clothes, I did, nothing really changed, but I got good calibration target once though.
    I currently use one extruder only and as I am very busy at work at the moment I have no time to work on dual extruder prints..
    My plan is to update firmware to v.6, clean the nozzles, recalibrate the printer and print calibration target again (I will try not to use cleaning clothes at all during calibration and printing).
    David, if there is a problem on the drivers, what kind of repair is required?

    #10099
    christian.gassner
    Participant

    Yesterday i have done 4 prints (2x via SD, 2x via USB and completely removed the cloth.
    1. It’s for sure not the cloth.
    2. via SD: right extruder tiny little thing too much right (could be accepted) => both prints show same result so i would close out any mechanical issue
    3. via USB: right extruder by far too left (unacceptable) => both prints show same result so i would close out any mechanical issue
    For me it looks like FW issue in printing via USB part.
    Remember … in v1.1.6 the M109 & M190 have been fixed for printing via USB. Bug could be introduced here???
    @vlad: Do you phase the issue also in priting via USB? Have you also tried via SD?

    #10111
    jamie
    Participant

    I managed to get mine calibrated the other day.
    I connected via Pronterface and sent an M500 command to reset the printer. After this I got it calibrated.
    Still it should be easier than this.

    #10114
    christian.gassner
    Participant

    Then we are talking about different issues.
    My Sigma saves the calibration without any issue.
    But when printing in dual mode VIA USB the noozles are not aligned.
    Printing the same gcode via SD is working well.

    #10121

    Hi Christian,
    Thanks for pointing out this issue. We never experienced that, but we will take a deeper look in order to find out the origin of the problem.
    Thanks for your patience.

    #10169
    vlad
    Participant

    @Christian.gassner – I print via SD card only, tried printing via USB…did not manage it.
    It seems the printer is not connecting. However firmware update worked well.
    After updating to v.6, cleaning the nozzles, removing the clothes, re-calibrating (matching lines are usually 5 or 6) I got the same result as before – left extruder is printing with about 0.5 mm offset to the left.
    I printed gcode generated by Cura first, then gcode from BCN (which was on SD card). I’m also attaching the photo of the print using support generated by Cura (older print).

    #10249

    Hi Christian,
    Thanks for the pictures. Just a question: Which software do you use to print via USB? So we can replicate the situation.
    Thanks

    #10259

    Hello,
    The new firmware version will have the option of fine tuning the offset through the LCD. Meanwhile you can try to correct the offset by modifying the stored values as explained in out github site. To get the values use the M503 command, and M530 to change them:
    #19 [Enhancement] New G-Code: M530. Command is case sensitive!
    X: X offset
    Y: Y offset
    Z: Z offset
    P: z-prove offset
    M530: Change calibrations offsets
    Format example: M530 X303.9 Y0.25 Z0.30 P-2.35.
    https://github.com/BCN3D/BCN3DSigma-Firmware/releases

    #10290
    christian.gassner
    Participant

    When printing from USB i am using Octoprint (on Raspberry Pi 2).
    The M530 i am already using for fine tuning. When printing vom SD everything is ok.

    #10531
    vlad
    Participant

    Thanks to David and Pronterface we’ve managed to adjust the X offset perfectly! Can’t complaint any more 🙂

    #10611
    Phill
    Participant

    It would be great if you could document it here for others?

    #10666
    vlad
    Participant

    Ok, here is the recap – how I’ve changed the X axis offset between two extruders:
    1 – right extruder (yellow) is printing with about 0.5 mm offset to the right;
    2 – download pronterface: http://koti.kapsi.fi/~kliment/printrun/
    3 – connect the printer to the computer via USB cable and open the software;
    4 – Press the connect button after selecting the port (COM3 and baudrate 250000) on pronterface and the printer should be online (check status on the right).
    5 – Type the first command M503 on the lower right bar and press enter
    M503 command recalls a lot of data including Offsets (mm): X…. Y…. Z…. Z probe…
    In my case X304.8
    6 – To change offset use M530 command and indicate desired new offset: M530 X305.2
    (I am not sure which of the two extruders was affected, let’s say by adding 0.4 mm second extruder started printing a bit to the left);
    7 – to save changes use command M500, the firmware will be updated;
    8 – print calibration target (small but very useful part)

    #10769

    Hello Phill,
    the process is explained on the first page of the topic:

    The new firmware version will have the option of fine tuning the offset through the LCD. Meanwhile you can try to correct the offset by modifying the stored values as explained in out github site. To get the values use the M503 command, and M530 to change them:
    #19 [Enhancement] New G-Code: M530. Command is case sensitive!
    X: X offset
    Y: Y offset
    Z: Z offset
    P: z-prove offset
    M530: Change calibrations offsets
    Format example: M530 X303.9 Y0.25 Z0.30 P-2.35.
    https://github.com/BCN3D/BCN3DSigma-Firmware/releases

    #11027
    vlad
    Participant

    Apparently we will need to adjust this X offset after every re-calibration. We’ve just swapped the 0.4 hot ends to 0.6 ones, re-calibrated the printer and there was the same nasty offset as before. It seems that the printer saves calibration values but adds (or misses) something else.

Viewing 21 posts - 1 through 21 (of 21 total)
  • You must be logged in to reply to this topic.